Ардупилот на платах OpenPilot Revolution / RevoMini (записей: 1738)

  • Аватар профиля venq73 DarkSoul Venq в 1 мес. назад
    [2018-06-18 05:53:19] chekanoff писал(а): UART3 (Serial4 в MP) должен работать.

    По доке с гитхаба \boards\f4light_MatekF405_CTR\1_read_me.md

    тут нет UART3

    И с UART2 я не понял, он разве не занят приёмником?

    ## Default connection
    | Function | Serial |
    | ------ | ------ |
    | USB | Serial0 in MP |
    | Telemetry | UART1 (Serial1) |
    | GPS | UART4 (Serial3) |
    | Built-in OSD | Serial2 |
    | UART2 | Serial4 |
    | UART5 | Serial5 |

  • Аватар профиля Chekanoff Chekanoff3 пунктов в 1 мес. назад

    Видимо, в доке ошибка. Должно быть uart3 (serial4)

  • Аватар профиля Night_Ghost Night_Ghost283 пунктов в 1 мес. назад
    [2018-06-18 12:34:49] chekanoff писал(а): Видимо, в доке ошибка.

    точно, поправил

  • Аватар профиля Night_Ghost Night_Ghost283 пунктов в 1 мес. назад
    [2018-06-18 08:49:26] sanyok84 писал(а): Оставляю на 40 минут. Через 40 минут включаю апу, запитываю борт - подается питание на приемник и наблюдаю то, что я выше описывал.

    Это несколько нестандартное подключение. При нормальном подключении - сначала батарея, потом USB - ничего похожего добиться не удалось

     

  • Аватар профиля Chekanoff Chekanoff3 пунктов в 1 мес. назад
    [2018-06-18 08:49:26] sanyok84 писал(а): Да, все четко воспроизводится: подключаю полетник к компу. Батарею не включаю (приемник РУ обесточен, PPM не приходит). Оставляю на 40 минут. Через 40 минут включаю апу, запитываю борт - подается питание на приемник и наблюдаю то, что я выше описывал.

    Попробуйте воспроизвести это же с другим приемником. Возможно дело в приемнике.

  • Аватар профиля sanyok84 sanyok84 в 1 мес. назад

    Тут дело не в последовательности подключения - я подключал так, ибо через 10 минут неактивности у меня начинает дико пищать есц. Если подключить батарею сразу - через минут 30-40 будет то же самое, собственно что посреди полета и произошло. Пробовал подключать другой модуль (точно такой же) с другого борта, где он исправно работает - без изменнеий. Единственное отличие, что бросается мне в глаза - у меня подключен аналоговый датчик воздушной скорости. Если Вас не затруднит - проведите пожалуйста эксперимент с моими параметрами https://yadi.sk/d/yaHhYa_z3YAFxR

    Я, в свою очередь, так же попробую выяснить - может какой-то определенный параметр, отличный от дефолта вызывает такое поведение.

  • Аватар профиля Night_Ghost Night_Ghost283 пунктов в 1 мес. назад
    [2018-06-20 10:38:37] sanyok84 писал(а): начинает дико пищать есц

    Для проверки можно отсоед

    [2018-06-20 10:38:37] sanyok84 писал(а): проведите пожалуйста эксперимент с моими параметрами

    У меня плата установлена в коптер, и прошивать самолетом как-то боязно. В самолете РевоМини и приемник от Walkera Aibao, проблем не обнаружено
    инить.

  • Аватар профиля Night_Ghost Night_Ghost283 пунктов в 1 мес. назад

    Давненько у нас новых версий не было :)

    • сделана трансляция SBUS флага Failsae в газ ниже 1000 дабы автопилот понимал такой failsafe.
    • улучшена работа драйвера MAG3110
    • улучшена работа барометра BMP280
    • добавлена возможность отключить коррекцию PWM для использования с ESC после разных Пиксов без перекалибровки.
    • исправлена инициализация пищалки для всех плат.
    • исправлена полярность пищалки для Matek-CTR
    • куча всего по мелочи.

    бинарники готовы

  • Аватар профиля lml lml1 пунктов в 1 мес. назад
    • добавлена возможность отключить коррекцию PWM для использования с ESC после разных Пиксов без 

     

     А как именно это делается?

  • Аватар профиля sanyok84 sanyok84 в 1 мес. назад
    [2018-06-20 11:05:55] night_ghost писал(а): У меня плата установлена в коптер

    Я попробовал с коптерной прошивкой - то же самое. Поменял модуль приемника Orange LRS на FlySky - то же самое. На прошивках BetaFlight и iNav ничего подобного не наблюдается, хоть час он постоит, хоть два... В моих последних экспериментах коптерная прошивка была Ваша крайняя, с дефолтным конфигом, ничего кроме приемника (PPM выход приемника подключен к пину SBUS) и GPS к полетнику не подключено. Когда это происходит, перетыкание приемника и замена на совершенно другой ситуацию не исправляют. Исправляет лишь перезагрузка полетного контроллера (и по питанию и программная). На китайском клоне Omnibus такого не происходило. Night_Ghost, попробуйте пожалуйста на вашем F405-CTR на коптерной прошивке принимать PPM 30-40 минут. У меня уже нет больше мыслей, а очень хочется летать на подобного плана контроллерах, без километров проводов и дополнительных модулей.

  • Аватар профиля Night_Ghost Night_Ghost283 пунктов в 1 мес. назад
    [2018-06-21 21:21:41] lml писал(а): А как именно это делается?

    Установкой параметра BRD_FREQ_CORR в 0

    [2018-06-21 23:47:26] sanyok84 писал(а): Я попробовал с коптерной прошивкой - то же самое.  [...] на вашем F405-CTR на коптерной прошивке принимать PPM 30-40 минут

    Сейчас у меня SBUS, PPM приемника под рукой нет. Найду - попробую

  • Аватар профиля Night_Ghost Night_Ghost283 пунктов в 1 мес. назад

    Собраны бинарники с последней версией из апстрима

  • Аватар профиля sanyok84 sanyok84 в 1 мес. назад

    Добавьте пожалуйста в описание информацию о баге с PPM (по крайней мере с F405-CTR) - когда на 35ой минуте полета теряется управление и все каналы начинают скакать - это очень печально и борт домой вернуть уже маловероятно. Переключил приемник на SBUS - проблема полностью ушла, но боюсь, что не все будут читать 114 страниц чтобы дойти до этого поста. Я прекрасно понимаю, что это все делается под настроение/возможности, поэтому не жду скорейшего исправления. Просто не хочется, чтобы люди бились или очередной кирпич кому-то на голову свалился.

  • Аватар профиля gppsoft Павел Горло в 4 нед., 1 дн. назад
    [2018-06-22 04:20:21] night_ghost писал(а): Собраны бинарники с последней версией из апстрима

    Omnibus F4 Pro V2. После прошивки, до мигания светодиодов(инициализации) проходит около минуты. 

  • Аватар профиля lml lml1 пунктов в 4 нед., 1 дн. назад
    [2018-06-22 03:06:35] night_ghost писал(а): Установкой параметра BRD_FREQ_CORR в 0 

    А это где-то задокументировано? 

← Форум группы   Все форумы К последней записи
Постов на странице:

Вы автоматически вступите в эту группу, когда ответите в теме.

Добавить ответ:

-
Рейтинг@Mail.ru